MSP-EXP430G2ET Compatibility

Discussion about deployment systems including altimeters, timers, air speed flaps, servo systems, and chemical reactions.
Post Reply
wmakaryk
New Member
Posts: 1
Joined: Thu Dec 06, 2018 10:47 am

MSP-EXP430G2ET Compatibility

Post by wmakaryk » Thu Dec 06, 2018 1:35 pm

I am doing my first build AlTImeter with parachute recovery. I followed the instructions on the website tutorial for this build and when I tried to order the 430G2 TI indicated that it is no longer available and the 430G2ET replaced it. I ordered the G2ET and followed the tutorial as best I could. The big difference is the battery power input is quite different and I followed TI's instructions to us the J4 pins for input. The rest of the assembly was straight forward and I followed the tutorial to program the firmware into the assembled device. The firmware loaded after an update which I assumed was needed and I got a pass on the installer. I then disconnected the PC and attached the battery. The Green and the Red LED come on constantly and there is a constant audible tone. Also the yellow and green LEDs on the FET upper portion stay on. Pressing the S2 button does nothing and pressing the S1 reset turns everything off while it is pressed, but everything comes back on when S1 is released. Any ideas what is interfering with normal operation?



User avatar
anachronist
WRA2 Member
WRA2 Member
Posts: 231
Joined: Sun May 07, 2017 2:18 pm

Re: MSP-EXP430G2ET Compatibility

Post by anachronist » Thu Dec 06, 2018 3:34 pm

You should probably post this in the Launchpad AlTImeter technical support forum here: viewtopic.php?f=5&t=2614



Post Reply