Launchpad AlTimeter external deploy output

Discussion about deployment systems including altimeters, timers, air speed flaps, servo systems, and chemical reactions.
Post Reply
salax54
New Member
Posts: 4
Joined: Wed Jan 22, 2020 1:13 pm

Launchpad AlTimeter external deploy output

Post by salax54 » Wed Jan 22, 2020 2:27 pm

Hey there fellas! New here, this is actually my second post. Anyway, i have purchased the Launchpad kit, along with the buzzer, and am waiting on the pressure sensor and LiPo battery to arrive.The whole setup looks pretty straightforward, but i have a tech question:
Reading on the online guide, there's a paragraph mentioning External Deploy Apogee Output. And i quote: "This method of recovery often uses an electrically ignited pyrotechnic device to eject a parachute. The LaunchPad AlTImeter provides a 3.6V digital signal which can be used to activate an external driver circuit for such a deploy system."
That's actually what i would like to do. Utilize some output to force a deployment charge, by sending power to an igniter at apogee. So i was wondering, if this 3.6V output (is it actually XIN, or is it the XOUT terminal? ) can be used to power the igniter. I'm not a programmer, so i have no knowledge to edit the code for such a case.
If at all feasible, will i also need any extra peripherals? At first i thought of maybe taking advantage of the servo and closing contacts of a microswitch at apogee, which in turn would end to the igniter, but would prefer a servo-less payload.
Thanks in advance for any advice!



User avatar
U.S. Water Rockets1
WRA2 Member
WRA2 Member
Posts: 1773
Joined: Sat Feb 03, 2007 3:24 pm

Re: Launchpad AlTimeter external deploy output

Post by U.S. Water Rockets1 » Sun Jan 26, 2020 12:02 am

Hi salax54. Welcome to the forum.

Basically, the way the circuit works is that the deploy output pin has been programmed to function as an external trigger signal. Ignore any markings on the board, because those marks are only calling out the default pin functions, which are overridden by the software. In this case the signal coming out is going to switch from 0V to 3.5V when the deploy is triggered. The only caveat is that the pin can only source a small amount of current, only a few milliamps. This is not enough to power an igniter by itself, but is intended to turn a FET transistor on. which is used to then power the igniter. If you look for examples how to use an N-Channel FET to power an igniter (or anything else, like a light bulb, or heater, or motor) there are hundreds of circuits you can clone and use out there. Alternatively. you can also use the deploy output to power an opto-coupler, which is essentially an LED which is fused to a light sensitive transistor switch. The signal turns on the LED and the light from the LED makes the transistor turn on, which completes the circuit. This type of arrangement is nice because the optical-coupler switch side is electrically isolated from the LED side, which means any shorts or malfunctions on the igniter end of the device cannot affect the LED side and anything connected before it. This reduces the risk of frying the altimeter with a short circuit in the igniter circuit. That's just an extra level of security you can add, but not strictly necessary if you are reasonably careful with your wiring.

Hopefully, this gives you some information to look at and you can make something that suits your particular needs. Good luck with the project!


Team U.S. Water Rockets
Visit USWaterRockets.com
Visit our Blog
Tune in to our YouTube Channel
Visit our Facebook page
Visit our Twitter Page
Opportunity is missed by most people because it is dressed in overalls and looks like work. --Thomas Edison

salax54
New Member
Posts: 4
Joined: Wed Jan 22, 2020 1:13 pm

Re: Launchpad AlTimeter external deploy output

Post by salax54 » Sun Jan 26, 2020 12:38 am

Thank you for your reply! My understanding is that i would probably need a means of re-programming the Launchpad to utilize triggering the deploy. Is this correct?
What would've happen if i was to power the igniter using the servo power line instead (with the servo missing)? Will the servo out still send voltage to the igniter on apogee? Dunno, but to me the whole concept should be rather simple: a means to send voltage to an igniter when the model reaches apogee. If necessary, adding a second battery to supply current for that.



User avatar
U.S. Water Rockets1
WRA2 Member
WRA2 Member
Posts: 1773
Joined: Sat Feb 03, 2007 3:24 pm

Re: Launchpad AlTimeter external deploy output

Post by U.S. Water Rockets1 » Sun Feb 02, 2020 12:35 am

The digital deploy output is what you need to fire a pyro deploy. You can use this to turn on the circuit that powers the charge. One possible way to do this is to get an off-the-shelf Solid-State-Relay that uses a 3.3V logic level input. This will be about the simplest solution.

You do not need to reprogram anything to make this work, because the ability to configure the deploy output is already built into the firmware. All you need to do is follow the configuration settings instructions to set up the deploy output signal to match the circuit that you've connected it to (for example to match the expected input of the Solid State Relay).

It would be very difficult to adapt the design to use the servo control signals for anything other than a servo. The servo has power and ground which are always active, plus a control signal which is a series of pulses which vary in duration to express the position of the servo in degrees. Technically, this could be read and interpreted by a microprocessor and turned into an On/Off signal for a pyro, but the O/Off signal is already provided on the Deploy Output pin of the launchpad Altimeter. You should just use that.

I hope this clears things up a bit.

Good luck!


Team U.S. Water Rockets
Visit USWaterRockets.com
Visit our Blog
Tune in to our YouTube Channel
Visit our Facebook page
Visit our Twitter Page
Opportunity is missed by most people because it is dressed in overalls and looks like work. --Thomas Edison

salax54
New Member
Posts: 4
Joined: Wed Jan 22, 2020 1:13 pm

Re: Launchpad AlTimeter external deploy output

Post by salax54 » Sun Mar 15, 2020 12:41 am

Thanks for your reply! Kinda gets clearer now. I am having a problem with the Launchpad installation itself... Now that all parts have arrived, i soldered the buzzer and the barometric sensor on the board as per the photos on the guide. But it appears i'm having a hard time with Windows!
First connection looked ok, but it was the only time the board appeared normally under devices [MSP430 application UART] . Some important details:
The suggested FET Lite program is actually a trial software, which lasts for 15 days. Had this installed without knowing it, and expired before receiving all the goodies to setup the board. Thus, i couldn't use it any more.
The code needed for programming the board is a file of the .FET430prj - which is an extension that appears to be utilized solely by that software [not readable by programs like Energia, CCS etc.]
Thus, i uninstalled the [expired] FET Lite program, and installed the Pro version [trial] which i assume should be able to read the file. However, the board isn't recognized properly by Windows 8.1 x64 anymore. I get an exclamation mark next to the device. I'm stuck with this situation for 2 days now, and do not know what to do. I even tried it on another pc using Windows 7 32-bit, but couldn't make it recognize the board properly either from the start. The Launchpad powers up, i see a green led continuously lighting, and a series of on and off of the other two leds green -- red.
Tried other cables, tried every USB port, managed to screw up the whole USB set at the Device Manager, and had to reinstall my pc drivers to bring things back to normal.
But still, the exclamation mark remains there..
When running FET Lite or pro, i get an error message about the 430.dll missing if i attempt to program the board. The dll is present, but i still get the error. .
Any ideas would be appreciated.



Post Reply